Dear Headless User, due an unplanned deploy, testing on Headless may be affected with intermittent downtimes, causing some tests to possibly fail. This outage is scheduled for about 3 hours maximum, between 7:00pm PDT - 10:00pm PDT on Thursday, August 8, 2019. Things are expected to be back to normal once the deploy has finished. We apologize for the inconvenience.
2020-November-19 Resolved Service Incident
Incident Report for Sauce Labs US East Data Center
Postmortem

Dates:

Thursday, November 19th 10:26 - 15:03 PST

What happened:

Customers weren't able to reach REST API endpoints that satisfied certain conditions. Those requests were mistakenly directed to a service that wasn't able to handle them.

Why it happened:

We merged a change that contained erroneous regular expressions and broke the main API router.

How we fixed it:

The breaking change was rolled back and we merged a fixed version at a later point.

What we are doing to prevent it from happening again:

We’re introducing thorough post-deploy tests that will cover the API routing.

Posted Nov 24, 2020 - 12:45 EST

Resolved
We detected errors on our REST API, Sauce Connect and UI for users with a sso prefix on their username. We took remedial action which resolved the issue. All services are fully operational.
Posted Nov 19, 2020 - 15:43 EST