Dear Headless User, due an unplanned deploy, testing on Headless may be affected with intermittent downtimes, causing some tests to possibly fail. This outage is scheduled for about 3 hours maximum, between 7:00pm PDT - 10:00pm PDT on Thursday, August 8, 2019. Things are expected to be back to normal once the deploy has finished. We apologize for the inconvenience.
2020-October-09 Service Incident
Incident Report for Sauce Labs US East Data Center
Postmortem

Dates:

Friday, October 9th between 8:08 AM and 9:00 AM EDT

What happened:

Customers using our US-EAST data center were unable to start Headless tests on Sauce Labs.

Why it happened:

Our GKE cluster’s control plane was unavailable during the time of the incident and it was unable to schedule new jobs.

How we fixed it:

The cluster underwent self-repair and its control plane became available again.

Posted Oct 20, 2020 - 06:01 EDT

Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 09:07 EDT
Monitoring
Headless tests are starting and service is returning to normal. We will continue to monitor the situation.
Posted Oct 09, 2020 - 08:42 EDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2020 - 08:35 EDT
Investigating
Headless tests are not starting. We are investigating.
Posted Oct 09, 2020 - 08:32 EDT
This incident affected: Headless Testing.