2021-January-19 Service Incident
Postmortem

Dates:

Tuesday, January 19, 2021 09:40 - 10:35 EST

What happened:

The dashboard for Sauce Labs Headless datacenter was non-operational for approximately 55 minutes starting at 9:40 am EST. Only requests from web browsers were affected. Requests sent by clients to the Sauce REST API were not affected.

Why it happened:

A SSL certificate which had not expired was revoked.

How we fixed it:

The revoked certificate was replaced with the new one.

What we are doing to prevent it from happening again:

We started to use a certificate management controller for API gateway in Headless. It will ensure certificates are valid and up to date and in case of any problem it will allow us to issue new certificates without undue delay.

Posted Jan 22, 2021 - 11:50 EST

Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 10:44 EST
Investigating
The Sauce Labs UI at https://app.us-east-1.saucelabs.com/dashboard/tests is not loading, due to a certificate issue. We are investigating.
Posted Jan 19, 2021 - 09:47 EST